NeoOffice 3.0 Early Access Development Issues

From NeoWiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 03:22, 14 November 2008 (edit)
Pluby (Talk | contribs)
(Move some issues to unconfirmed as the behavior with the 11/13/2008 test patch appears the same as NeoOffice 2.2.5)
← Previous diff
Revision as of 17:32, 15 November 2008 (edit) (undo)
Samwise (Talk | contribs)
m (Unconfirmed issues)
Next diff →
Line 3: Line 3:
== Unconfirmed issues == == Unconfirmed issues ==
 +* Button flicker when using DateIssu.odb file from [http://bugzilla.neooffice.org/bug.php?op=show&bugid=3044 bug 3044] (to reproduce, Ctrl-click on the Form, choose Open). No flicker in 2.2.5 with the same file.
* Rulers display in "Characters" despite being set to "Inches" everywhere in Preferences (edit by pluby: I cannot reproduce this with the 10/31/2008 test build) (I can reproduce this in the 10/31/2008 build when it migrates existing 2.2 prefs. In fact, I get completely different sets of preferences in Writer:General when Neo3 imports Neo2 prefs vs not importing prefs. —[[User:Sardisson|sardisson]]) * Rulers display in "Characters" despite being set to "Inches" everywhere in Preferences (edit by pluby: I cannot reproduce this with the 10/31/2008 test build) (I can reproduce this in the 10/31/2008 build when it migrates existing 2.2 prefs. In fact, I get completely different sets of preferences in Writer:General when Neo3 imports Neo2 prefs vs not importing prefs. —[[User:Sardisson|sardisson]])
*Old icons are used in toolbars if toolbar preferences are copied over manually from the 2.2 preferences file. (I realize this may not be a bug, but I thought I should report it. My toolbar settings did not transfer over automatically, so I copied the relevant folder. But then I lost the nice new icons!) On a PPC machine. *Old icons are used in toolbars if toolbar preferences are copied over manually from the 2.2 preferences file. (I realize this may not be a bug, but I thought I should report it. My toolbar settings did not transfer over automatically, so I copied the relevant folder. But then I lost the nice new icons!) On a PPC machine.

Revision as of 17:32, 15 November 2008

This page is for tracking any issues that we find during development of the NeoOffice 3.0 Early Access. Once NeoOffice 3.0 Early Access is released, we will record all issues in Bugzilla.

Contents

Unconfirmed issues

  • Button flicker when using DateIssu.odb file from bug 3044 (to reproduce, Ctrl-click on the Form, choose Open). No flicker in 2.2.5 with the same file.
  • Rulers display in "Characters" despite being set to "Inches" everywhere in Preferences (edit by pluby: I cannot reproduce this with the 10/31/2008 test build) (I can reproduce this in the 10/31/2008 build when it migrates existing 2.2 prefs. In fact, I get completely different sets of preferences in Writer:General when Neo3 imports Neo2 prefs vs not importing prefs. —sardisson)
  • Old icons are used in toolbars if toolbar preferences are copied over manually from the 2.2 preferences file. (I realize this may not be a bug, but I thought I should report it. My toolbar settings did not transfer over automatically, so I copied the relevant folder. But then I lost the nice new icons!) On a PPC machine.
  • Drawing metrics off for combo boxes; the popup buttons on the right hand side of non-editable combo boxes are a few pixels misaligned to the right and top. Editable seems fine, but not all of the region is updated when going from disabled to enabled (Tools > Options > NeoOffice > Fonts, check/uncheck "Apply Replacement Table") (edit by pluby: does this still occur in the 11/13/2008 test patch?)
  • Frame widget types not functioning in Tools > Spelling and Grammar (edit by pluby: does this still occur in the 11/13/2008 test patch?)
  • Frame wells in Templates and Documents are Win95 style, not OS X style. Also see table list in Tools > Options > NeoOffice > Fonts (edit by pluby: does this still occur in the 11/13/2008 test patch?)
  • List Box wells are Win95 style, not OS X widgets (see Help > NeoOffice Help, both search term list and rendered content area) (edit by pluby: does this still occur in the 11/13/2008 test patch?)

Unfixed issues

  • Printing in Writer with View :: Web View menu set: after NeoOffice print options dialogue closes, main doc window shows hidden characters (e.g. paragraph marks) and then hides them again.
  • Scrollbar hit testing does not match arrows when double-arrows preference is set
  • Focus rings for edit fields are not properly erasing...missing forced updates from our previous custom code on losing and gaining focus. See shifting focus in Tools > Options in the panel for entering user name and info...focus rings are not erased when tabbing through edit fields
  • Unusual continual redrawing of document boundary and uneven cursor timer flashing in documents opened from finder if the window is moved prior to final document opening.
  • Link to "get more templates online" goes to go-oo.org...probably others for extensions maybe? Redirect to our own site?
  • Investigate Tools > Options > NeoOffice > Online Update > Download Updates Automatically...what do we need to do? Change implementation, or remove?
  • Save icon is not dim when new document opened and does not dim when changes saved.

Closed

OpenOffice.org bug

  • Note: redundant extra column (but not extra row) in the Table button graphical size selector (which you get if you click on the dropdown triangle instead of the button) is an OpenOffice v3 bug, not a NeoOffice bug.
  • When opening documents, moving the window while document is opening does not preserve position; window will jump back after documents are opened

ooo-build bug

  • Note: wrong description for 'Toggle Grid Lines for the Current Sheet' button in Formatting toolbar, when viewed in Tools::Customise::Toolbars (it has the one meant for Edit::Changes::Record) - this is an ooo-build bug, they're going to fix it.
  • Calc: after copying a cell (or cells) to the clipboard (using e.g. cmd-c), a pale blue frame is drawn round that cell - visible when using Toggle Grid Lines. Doesn't go away until another selection is copied to the clipboard.

Not a bug - Feature Request

  • NeoOffice 3 installer immediately runs NeoOffice, doesn't let me install a patch first if I have it. Better behaviour would be to ask if NeoOffice should be started. (edit by pluby: this behavior has been standard in the NeoOffice installation since NeoOffice 2.1 so closing as this is a feature request)

Fixed issues

  • Italic angle in Writer in wrong (fixed in 10/15/2008 test patch)
  • NeoOffice :: About and NeoOffice :: Preferences do not work (fixed in 10/15/2008 test patch)
  • Start Center shows when all documents are closed (fixed in 10/15/2008 test patch)
  • None of the Tools :: Add-ons work (fixed in 10/15/2008 test patch)
  • Splash screen progress bar flickers (fixed in 10/15/2008 test patch)
  • Enable odf-converter for export of Office 2007/2008 files (fixed in 10/21/2008 test build)
  • Upgrade to odf-converter 2.0 code (fixed in 10/21/2008 test build)
  • Crashes when launched by opening a document in the Finder (fixed in 10/21/2008 test build)
  • Exported PDF files have corrupted embedded fonts (fixed in 10/21/2008 test build)
  • Image Capture extension is still not properly loading (10.5 PowerPC), but issues with grammar and media browser service loading are resolved (fixed in 10/21/2008 test build)
  • On PowerPC, dlopen() function calls for module libraries (libsw, libsc, etc.) are 10 times slower than in earlier OOo versions (fixed in 10/21/2008 test build)
  • Native spellchecker code is not being loaded (fixed in 10/21/2008 test build)
  • Dragging within NeoOffice does not work but dragging to or from other apps works (fixed in 10/21/2008 test build)
  • Extension Manager - updates to bundled Presentation Minimiser & Presenter Console not possible: 'The extension cannot be installed because: No write permission (shared extension).' (fixed in 10/31/2008 test build by disabling update check for read-only shared extensions)
  • Possible font cache corruption, see bug 3273 (fixed in 10/31/2008 test build)
  • Extension Manager - installing AltSearch.oxt extension breaks Extension Manager; all buttons greyed out except Help and Close, not possible to select other extensions. (fixed in 10/31/2008 test build)
  • Update problems in Extension Manager; simply scroll list, note that not all icons to the left of entries are not always drawn. PowerPC (fixed in 10/31/2008 test build)
  • On PowerPC, icon for media browser extension in toolbar does not display (fixed in 10/31/2008 test build)
  • Toolbar icons in Writer that get obscured by tooltips do not redraw properly; portion of icon that was obscured does not get repainted (fixed in 10/31/2008 test build)
  • Tooltip drawing/updates over tables can undo XOR drawing: Create table in writer with multiple rows, select entire table, move mouse over boundary positions just to the left of left table edge to get "Select row" style tooltips, watch XOR get reversed when obscured portion is unnecessarily redrawn (fixed in 10/31/2008 test build)
  • Scrolling with scrollbar that causes tooltips to appear for Headings in a Writer document may result in portions of writer document that were obscured by the tooltips from being redrawn properly (fixed in 10/31/2008 test build)
  • Change Thesaurus module to use PRODUCT_NAME (Tools > Options > Language Settings > Writing Aids > Available Language Modules) (fixed in 10/31/2008 test build)
  • "Close" button in the popup lightbulb help assistant no longer displays the "X" to close...it's now just an empty well. (fixed in 10/31/2008 test build)
  • Size adjustment handles not appearing on images embedded in Writer documents (e.g. blue square handles to change horizontal/vertical bounds) (edit by pluby: I cannot reproduce this with the 10/31/2008 test build) (Ed - verified fixed in 10/31/08 test build)
  • Attempting to adjust scrollbar by click-dragging thumb will cause thumb of scrollbar to disappear, text to scroll to top (Ed - fix committed 11/9/08) (fixed in 11/13/2008 test patch)
  • Frame widget types not functioning (see Tools > Options sub panels in the right...the Win95ish panel should be replaced with the native frame widget type, similar to a tab well background) (Ed- fix committed 11/9/08) (fixed in 11/13/2008 test patch)
  • 'Check for Updates' flags a patch-0 update as available, but Download button goes to EAP postponement web page. (fixed in 11/13/2008 test patch)
  • Listboxes and comboboxes are clipped (fixed in 11/13/2008 test patch)
  • Spinners do not render natively (fixed in 11/13/2008 test patch)
  • Text fields are too small (fixed in 11/13/2008 test patch)
  • Tools>Customize>Keyboard: If I try to drag the scroll lozenge (the little blue oval), it disappears. It only reappears when one of the scroll arrows is clicked on. Scrolling is only possible with the arrows, and then is often inconsistent. This is on a PPC machine. More: The same is true of the scroll lozenges in the main document window. The mouse scroll ball and scrolling on the trackpad work correctly, and the lozenges move in sync with this scrolling.—Lorinda (fixed in 11/13/2008 test patch)
  • Text in spinners' text fields exhibits "cheap whore" behavior (fixed in 11/13/2008 test patch)
  • Redundant separator in Help menu after "Check for Updates" (fixed in 11/13/2008 test patch)
  • Media Browser customizations for including NeoOffice Gallery in Photos and Music need to be updated to refer to the new path locations in the tri-level structure breakdown (fixed in 11/13/2008 test patch)
  • Need to check the online help content displayed by Help > Support to use corrected PRODUCT_NAME and our own support URLs (or redirect Support to open Trinity forums in a browser). (fixed in 11/13/2008 test patch)
  • Double-clicking timing issue on PowerPC seems to have reappeared; need to triple-click to select word in Writer instead of double-click. This was fixed by 2.2.5 patch 1 (?) so may be missing code that needs to be merged from the branch to HEAD (fixed in 11/13/2008 test patch)
Personal tools