NeoOffice 3.0 Early Access Development Issues

From NeoWiki

Jump to: navigation, search
Warning! (click icon for its license info) This page is no longer used and new issues should not be reported here. Please report any NeoOffice 3.0 Early Access issues in Bugzilla.

Contents

[edit] Unconfirmed issues

  • Using Cmd-O multiple times (e.g. 5) displays the Open dialog; after closing the dialog (clicking Cancel), another dialog appears, until you close all 5 dialogs. In 2.2.5, only one dialog can be opened, except when all windows are closed, where multiple dialogs do open but all show (whereas there is only one dialog showing at a time in 3.0). (edit by pluby: I can reproduce this in NeoOffice 2.2.5, can you?) Bug 3327
  • Rulers display in "Characters" despite being set to "Inches" everywhere in Preferences (edit by pluby: I cannot reproduce this with the 10/31/2008 test build) (I can reproduce this in the 10/31/2008 build when it migrates existing 2.2 prefs. In fact, I get completely different sets of preferences in Writer:General when Neo3 imports Neo2 prefs vs not importing prefs. —sardisson) Bug 3328
  • Old icons are used in toolbars if toolbar preferences are copied over manually from the 2.2 preferences file. (I realize this may not be a bug, but I thought I should report it. My toolbar settings did not transfer over automatically, so I copied the relevant folder. But then I lost the nice new icons!) On a PPC machine. Bug 3329
  • Drawing metrics off for combo boxes; the popup buttons on the right hand side of non-editable combo boxes are a few pixels misaligned to the right and top. Editable seems fine, but not all of the region is updated when going from disabled to enabled (Tools > Options > NeoOffice > Fonts, check/uncheck "Apply Replacement Table") (edit by pluby: does this still occur in the 11/13/2008 test patch?) Edit by Samwise: still occurs for me with the 11/13 test patch; use same steps as above (check/uncheck "Apply Replacement Table"). (another edit by pluby: is the behavior in the 11/21/2008 test patch any different than NeoOffice 2.2.5?) (The behaviors with editable comboboxes appear to be equally buggy in NeoOffice 2.2.5; oddly enough, the font replacement comboboxes redraw to disabled without alignment errors when the app or window becomes background, but not when being disabled by the checkbox. Other editable comboboxes, like the Styles combobox in the Writer toolbar, exhibit the redraw alignment error when their window becomes background. I don't observe any redraw issues with non-editable comboboxes, such as the Resolution one in Preferences:NeoOffice:Print. —sardisson) Bug 3330
  • Frame widget types not functioning in Tools > Spelling and Grammar (edit by pluby: does this still occur in the 11/21/2008 test patch?) Bug 3331
  • Frame wells in Templates and Documents are Win95 style, not OS X style. Also see table list in Tools > Options > NeoOffice > Fonts (edit by pluby: does this still occur in the 11/21/2008 test patch?) Bug 3332
  • List Box wells are Win95 style, not OS X widgets (see Help > NeoOffice Help, both search term list and rendered content area) (edit by pluby: does this still occur in the 11/21/2008 test patch?) Bug 3332
  • Unusual continual redrawing of document boundary and uneven cursor timer flashing in documents opened from finder if the window is moved prior to final document opening. (edit by pluby: does this still occur in the 11/21/2008 test patch?) Bug 3333
  • Can't access custom macros created in NeoOffice 2.2.5. I've moved over the basic folder from the 2.2.5 preferences, but Neo 3.0EA isn't able to find them. This is on a PPC machine running 10.4.11. [time passes] O.k. this is bizarre. Now the macros show up just where they are supposed to in NeoOffice 3.0 EA. I don't know what changed, although I did get several Basic errors when starting the app up this time. Bug 3334
  • I am now getting "Error Loading Basic" messages when starting NeoOffice 3.0 EA. The same screen appears twice, but once I've clicked OK in both of them, the application opens fine. Since the file in question is buried in the NeoOffice app itself, I'm not sure how to clear it. IIRC this started after I ran Neo 2.2.5 because I needed a macro I couldn't access from 3.0 EA. Here's a screen shot, since the path is so long (and not copyable):
    Image:Error Loading Basic.png
    Moving my preferences folder eliminated the errors. Pluby thinks the problem was related to one of my custom macros. When I have time I will see if I can track down which one.
  • Aqua focus rings on pop-up menus (e.g., "Help formatting" in Preferences:NeoOffice:General) are clipped. Bug 3335
  • Aqua focus rings on editable comboboxes (e.g., in the Find/Replace dialogue) are clipped. Bug 3335
  • Cannot Dock the Styles and Formatting palette. To reproduce: Click on the Styles and Formatting button on the toolbar. In the new window, hold down the command key and double-click in the grey area just under the window name. Nothing happens. (Sometimes this is true in 2.2.5 as well.) Second method: drag the window to the left or right edge of the main document window and pause. in Neo 2.2.5, in a second or two a grey box outline will appear. If you let go of the window when it does, it will dock the palette on that side. This does not happen in NeoOffice 3.0. The Help file says it should work that way. Bug 3336
    (Isn't that supposed to be Cmd-double-click? That WFM on 10.5/Intel, as does dragging; it's a bit harder than I remember to find/hold the position to trigger docking, but it does work here. —sardisson)
    You're right about Cmd-double-click. That's what I was trying, but not what I wrote. I've now corrected it. I'm on 10.4.11/PPC, so maybe that's the difference? --Lorinda
    This is still an issue for me in the 12/15/08 build. I can dock toolbars like the media browser by either command-double-click on the grey area, or by dragging to an edge. But I cannot dock the Styles And Formatting palette using any technique. --Lorinda
  • When printing, Hidden characters (paragraph marks, etc.) appear in the document briefly. File>Print>OK (or Preview). Then click OK in the Neo-specific dialog. Watch the document in Neo: Hidden characters will suddenly appear, then disappear. This does not happen in Neo 2.2.5. Bug 3337
    This is partially fixed for me in the 12/15/08 build. The hidden characters no longer appear, but the entire document becomes blank briefly during the printing process. This does not happen in Neo 2.2.5. PPC, 10.4.11. I just tested with a .doc file stored on my iDisk. I'll check a local file later today
  • Instability in Base File. I created a new Database document, which connects to an xls spreadsheet which has three sheets of data. Sometimes certain actions wouldn't work properly, at other times they would. More than once when I was creating a new Query in Design view I couldn't save it. I would choose Save, and the dialog would appear, I would give the name to the query and click ok. The dialog would disappear, but the save icon on the toolbar would not fade, and when I tried to close the Query window, it would tell me it wasn't saved. Clicking "Save" in that dialog had the same effect. At other times, creating a Query worked fine. Similarly, I tried to duplicate a Query by copying and pasting in the main Database document, and it wouldn't work. I followed all the standard procedure, but nothing happend. Sometimes closing the base document and reopening it cleared this up. Other times it didn't. Finally I quit and restarted NeoOffice. Then I got a document recovery dialog for the database file. I recovered it, and things worked o.k. for a while, before becoming unstable again. I have been presented with the recovery dialog every time I've started NeoOffice 3.0 EA Beta since. If someone needs more exact steps to reproduce, send me a pm via trinity and I'll provide them for you; they'd take up a ton of room here. PPC 10.4.11--Lorinda Bug 3338
  • Icons at the top of the Styles and Formatting window in the 12/15/08 build are smaller and harder to distinguish than those of previous builds. (edit by pluby: the icons in that window are the exact same size and the same icons as those in OpenOffice.org 3.0 so maybe you were using a custom icon set in your previous build?) (edit by Lorinda: I didn't use a custom icon set, but the difference I'm seeing may well be between 2.2.5 and 3.0. If that's the case, I just didn't notice the icon changes until the latest build. I'll consider the matter closed at this point).
  • Shift-left arrow and Shift-right arrow do not select the character to the left (or right) of the cursor. I'm pretty sure that this problem is new to the 12/15/08 build. If I go to Tools>Customize>Keyboard, the list says that these key combinations are correctly assigned. PPC 10.4.11 Bug 3339

[edit] Unfixed issues

  • Link to "get more templates online" goes to go-oo.org...probably others for extensions maybe? Redirect to our own site? Bug 3340
  • Investigate Tools > Options > NeoOffice > Online Update > Download Updates Automatically...what do we need to do? Change implementation, or remove? Bug 3341
  • The text-field part of a spinner widget gets a partial focus ring drawn around it (as opposed to no focus ring at all in 2.2.5 or a full focus ring for normal text fields in 3.0EA); see "Scaling" spinner in Preferences:NeoOffice:View. Bug 3342

[edit] Closed

[edit] OpenOffice.org bug

  • Note: redundant extra column (but not extra row) in the Table button graphical size selector (which you get if you click on the dropdown triangle instead of the button) is an OpenOffice v3 bug, not a NeoOffice bug. [edit, yoxi: this is still not fixed in OOo 3.0.1, and the drag-to-choose-table-size functionality is currently broken in the 3.1 branch]
  • When opening documents, moving the window while document is opening does not preserve position; window will jump back after documents are opened

[edit] ooo-build bug

  • Calc: after copying a cell (or cells) to the clipboard (using e.g. cmd-c), a pale blue frame is drawn round that cell - visible when using Toggle Grid Lines. Doesn't go away until another selection is copied to the clipboard.

[edit] Not a bug - Feature Request

  • NeoOffice 3 installer immediately runs NeoOffice, doesn't let me install a patch first if I have it. Better behaviour would be to ask if NeoOffice should be started. (edit by pluby: this behavior has been standard in the NeoOffice installation since NeoOffice 2.1 so closing as this is a feature request)
  • Default downloads destination (in Online Update preferences) should use default Mac OS X download directory from LaunchServices/InternetConfig rather than hard-coding ~/Downloads.
  • There seem to be options in the Menu::NeoOffice::Preferences that are used in OOo code, but not in the nativied NeoOffice replacements. I presume the settings for using native file and print dialogs, OpenGL, screen font anti-aliasing, show icons in menus and (possibly) proxy are obsolete and superseded by things inherited from OSX. It might be good to gray these out, even if they cannot be entirely removed. If not, at least documentation should be somewhere that tells a user what these settings still accomplish (ovvldc).
  • Checkboxes and radiobuttons have no focus rings (this seems to have existed since Aqua widgets landed in Neo).

[edit] Mac OS X bug

  • "soffice.bin[75472]: CFDictionarySetValue(): immutable collection 0x32e306d0 given to mutating function" in Console, related to printing (need to check 3.0.1; just stashing here until I get so I don't forget —sardisson) (edit by pluby: this appears to be a message from your print driver as our code does not call that function anywhere in our print code)

[edit] Fixed issues

  • Italic angle in Writer in wrong (fixed in 10/15/2008 test patch)
  • NeoOffice :: About and NeoOffice :: Preferences do not work (fixed in 10/15/2008 test patch)
  • Start Center shows when all documents are closed (fixed in 10/15/2008 test patch)
  • None of the Tools :: Add-ons work (fixed in 10/15/2008 test patch)
  • Splash screen progress bar flickers (fixed in 10/15/2008 test patch)
  • Enable odf-converter for export of Office 2007/2008 files (fixed in 10/21/2008 test build)
  • Upgrade to odf-converter 2.0 code (fixed in 10/21/2008 test build)
  • Crashes when launched by opening a document in the Finder (fixed in 10/21/2008 test build)
  • Exported PDF files have corrupted embedded fonts (fixed in 10/21/2008 test build)
  • Image Capture extension is still not properly loading (10.5 PowerPC), but issues with grammar and media browser service loading are resolved (fixed in 10/21/2008 test build)
  • On PowerPC, dlopen() function calls for module libraries (libsw, libsc, etc.) are 10 times slower than in earlier OOo versions (fixed in 10/21/2008 test build)
  • Native spellchecker code is not being loaded (fixed in 10/21/2008 test build)
  • Dragging within NeoOffice does not work but dragging to or from other apps works (fixed in 10/21/2008 test build)
  • Extension Manager - updates to bundled Presentation Minimiser & Presenter Console not possible: 'The extension cannot be installed because: No write permission (shared extension).' (fixed in 10/31/2008 test build by disabling update check for read-only shared extensions)
  • Possible font cache corruption, see bug 3273 (fixed in 10/31/2008 test build)
  • Extension Manager - installing AltSearch.oxt extension breaks Extension Manager; all buttons greyed out except Help and Close, not possible to select other extensions. (fixed in 10/31/2008 test build)
  • Update problems in Extension Manager; simply scroll list, note that not all icons to the left of entries are not always drawn. PowerPC (fixed in 10/31/2008 test build)
  • On PowerPC, icon for media browser extension in toolbar does not display (fixed in 10/31/2008 test build)
  • Toolbar icons in Writer that get obscured by tooltips do not redraw properly; portion of icon that was obscured does not get repainted (fixed in 10/31/2008 test build)
  • Tooltip drawing/updates over tables can undo XOR drawing: Create table in writer with multiple rows, select entire table, move mouse over boundary positions just to the left of left table edge to get "Select row" style tooltips, watch XOR get reversed when obscured portion is unnecessarily redrawn (fixed in 10/31/2008 test build)
  • Scrolling with scrollbar that causes tooltips to appear for Headings in a Writer document may result in portions of writer document that were obscured by the tooltips from being redrawn properly (fixed in 10/31/2008 test build)
  • Change Thesaurus module to use PRODUCT_NAME (Tools > Options > Language Settings > Writing Aids > Available Language Modules) (fixed in 10/31/2008 test build)
  • "Close" button in the popup lightbulb help assistant no longer displays the "X" to close...it's now just an empty well. (fixed in 10/31/2008 test build)
  • Size adjustment handles not appearing on images embedded in Writer documents (e.g. blue square handles to change horizontal/vertical bounds) (edit by pluby: I cannot reproduce this with the 10/31/2008 test build) (Ed - verified fixed in 10/31/08 test build)
  • Attempting to adjust scrollbar by click-dragging thumb will cause thumb of scrollbar to disappear, text to scroll to top (Ed - fix committed 11/9/08) (fixed in 11/13/2008 test patch)
  • Frame widget types not functioning (see Tools > Options sub panels in the right...the Win95ish panel should be replaced with the native frame widget type, similar to a tab well background) (Ed- fix committed 11/9/08) (fixed in 11/13/2008 test patch)
  • 'Check for Updates' flags a patch-0 update as available, but Download button goes to EAP postponement web page. (fixed in 11/13/2008 test patch)
  • Listboxes and comboboxes are clipped (fixed in 11/13/2008 test patch)
  • Spinners do not render natively (fixed in 11/13/2008 test patch)
  • Text fields are too small (fixed in 11/13/2008 test patch)
  • Tools>Customize>Keyboard: If I try to drag the scroll lozenge (the little blue oval), it disappears. It only reappears when one of the scroll arrows is clicked on. Scrolling is only possible with the arrows, and then is often inconsistent. This is on a PPC machine. More: The same is true of the scroll lozenges in the main document window. The mouse scroll ball and scrolling on the trackpad work correctly, and the lozenges move in sync with this scrolling.—Lorinda (fixed in 11/13/2008 test patch)
  • Text in spinners' text fields exhibits "cheap whore" behavior (fixed in 11/13/2008 test patch)
  • Redundant separator in Help menu after "Check for Updates" (fixed in 11/13/2008 test patch)
  • Media Browser customizations for including NeoOffice Gallery in Photos and Music need to be updated to refer to the new path locations in the tri-level structure breakdown (fixed in 11/13/2008 test patch)
  • Need to check the online help content displayed by Help > Support to use corrected PRODUCT_NAME and our own support URLs (or redirect Support to open Trinity forums in a browser). (fixed in 11/13/2008 test patch)
  • Double-clicking timing issue on PowerPC seems to have reappeared; need to triple-click to select word in Writer instead of double-click. This was fixed by 2.2.5 patch 1 (?) so may be missing code that needs to be merged from the branch to HEAD (fixed in 11/13/2008 test patch)
  • Button flicker when using DateIssu.odb file from bug 3044 (to reproduce, Ctrl-click on the Form, choose Open). No flicker in 2.2.5 with the same file. (fixed in 11/21/2008 test patch)
  • Printing in Writer with View :: Web View menu set: after NeoOffice print options dialogue closes, main doc window shows hidden characters (e.g. paragraph marks) and then hides them again. (fixed in 11/21/2008 test patch)
  • Scrollbar hit testing does not match arrows when double-arrows preference is set (fixed in 11/21/2008 test patch)
  • Focus rings for edit fields are not properly erasing...missing forced updates from our previous custom code on losing and gaining focus. See shifting focus in Tools > Options in the panel for entering user name and info...focus rings are not erased when tabbing through edit fields (fixed in 11/21/2008 test patch)
  • Save icon is not dim when new document opened and does not dim when changes saved. (fixed in 12/15/2008 test build)
  • Does the MediaWiki integration work (Preferences:Internet:MediaWiki)? If not, can we suppress it? I can't get it to establish a connection with the NeoWiki or Camino wiki. —sardisson (edit by pluby: the network connectivity code in this extension is apparently buggy so I will remove this extension in the next full test build) (fixed in 12/15/2008 test build)
  • Writer uses a new/wrong "Spelling and Grammar" icon, while Calc and everything else still uses the correct icon. (edit by pluby: does Armando know about this?) (fixed in 12/15/2008 test build)
  • Unlike other widgets, checkboxes and radio buttons don't switch to grey when their window or the app goes to the background (bug exists in 2.2.5 on 10.5.5/Intel/Java1.5 also, but *not* in 2.2.5 on 10.3.9/PPC/Java1.4,2; does it work correctly in 3.0EA on PPC, or on 10.4/Intel or other combinations?). (edit by pluby: this bug occurs in both 2.2.5 and 3.0 EA but only on Mac OS X 10.5.x so I have filed bug 3305) (fixed in 12/15/2008 test build)
  • Ctrl-A and Ctrl-E do not move the cursor to the beginning or end of line. (fixed in 12/15/2008 test build)
  • Base file on iDisk cannot be modified. This is a "native" Base file using the built-in DB engine. I can open it, but if i attempt to create a new form, I get the following error message:
    Image:IDiskConnection.jpg
    This does not happen in NeoOffice 2.2.5 I can open the same file without difficulties. (Fixed in 12/15/2008 test build)
  • Note: wrong description for 'Toggle Grid Lines for the Current Sheet' button in Formatting toolbar, when viewed in Tools::Customise::Toolbars (it has the one meant for Edit::Changes::Record) - this is an ooo-build bug, they're going to fix it. [edit, yoxi: fixed now...] (fixed in 12/15/2008 test build)
Personal tools