It:Le funzioni SOMMA.SE e MATR.SOMMA.PRODOTTO in Calc

From NeoWiki

Jump to: navigation, search
Questo articolo non è aggiornato, o ha bisogno di cambiamenti strutturali o stilistici per conformarsi al resto del wiki. Puoi aiutare alla comunità di NeoOffice sistemandolo.

La funzione SOMMA.SE appartiene alla categoria delle funzioni matematiche mentre la funzione MATR.SOMMA.PRODOTTO appartiene alle funzioni matrice. Queste funzioni permettono di lavorare con intervalli di celle che soddisfano qualche criterio. Prima di descriverle è bene spiegare la differenza tra una funzione (o formula) ed una funzione di matrice (o formula di matrice).

[edit] Formule e Formule di matrice

Una formula di matrice (o funzione di matrice) ti permette di svolgere calcoli che coinvolgono valori presenti in una matrice, p.e. in un intervallo rettangolare formato da almeno due celle adiacenti. Questa formula può gestire diversi valori simultaneamente. Può dare come risultato diversi valori, in modo che tu non sia costretto a riempire le celle di un intervallo trascinando il puntatore che si trova nell'angolo in basso a destra di una cella. Il risultato di una formula di matrice è un'altra matrice. Per confermare i dati in una formula di matrice devi premere i tasti Command-Shift-Invio. La formula viene inserita tra virgolette, ma non è possibile creare una fomula di matrice digitando manualmente le virgolette nella barra della formula.

Esempioe

Supponiamo che l'intervallo di celle A1:A20 contenga dei valori numerici. Per mostrare il risultato del prodotto tra i numeri contenuti in ognuna delle celle per 5 nell'intervallo di celle B1:B20 abbiamo due possibilità:
1) Clicca nella cella B1, digita la formula formula:

=A1*5

poi premi il tasto Invio. Adesso riempi l'intervallo di celle B1:B20 trascinando il puntatore. Vedi l'articolo Selecting and Filling a Cell Range (en) in questo stesso wiki.

2) Clicca nella cella B1, digita la formula:

=A1:A20*5

poi premi Command-Shift-Invio.
L'intervallo B1:B20 viene automaticamente riempito.

[edit] Funzione SOMMA.SE

Questa è una funzione matematica e non una funzione di matrice. Permette di sommare un intervallo di celle che costituiscono una matrice e soddisfano un certo criterio. Questi criteri devono essere un numero o una stringa. La sintassi è:

=SOMMA.SE(intervallo_da_controllare;criterio;intervallo_somma)

Supponiamo che l'intervallo A1:A20 contenga determinati valori numerici interi.

  • Per sommare i numeri dispari di questo intervallo devi usare una colonna ausiliaria, per esempio la colonna B, che mostri la parità delle celle presenti nell'intervallo A1:A10.
  • Nella cella B1, scrivi la formula :
=VAL.DISPARI(A1:A20)
e premi i tasti Command-Shift-Invio.
  • In una cella vuota, scrivi la formula:
=SOMMA.SE(B1:B20;1;A1:A20)

o

=SOMMA.SE(B1:B20;"VERO";A1:A20)
e premi il tasto Invio.
  • Per la somma dei numeri nell'intervallo A1:A20 che è maggiore della media di questo intervallo, non c'è bidogno di una colonna ausiliaria, puoi scrivere la formula seguente in una cella vuota:
=SOMMA.SE(A1:A20;">"&MEDIA(A1:A20);A1:A20)


NotA – PUOI SOSTITUIRE LA FUNZIONE Somma.se con la formula di matrice SOMMA. La sintasi di questa funzione è:

=SOMMA((intervallo=criterio)*(somma_intervallo))

Per esempio, nei casi sopra esposti, puoi digitare:

=SOMMA((B1:B20=1)*(A1:A20))

or

=SOMMA((A1:A20>MEDIA(A1:A20))*(A1:A20))

in una cella vuota, e premere Command-Shift-Invio.

[edit] Funzione MATR.SOMMA.PRODOTTO

Supponiamo di nuvo che l'intervall A1:A20 contenga valori numerici.

La funzione MATR.SOMMA.PRODOTTO è una funzione di matrice. Visto che il risultato è un singolo numeri, può essere immassa premendo solo il tasto Invio. Questa funzione può essere usata:
1) per calcolare il prodotto scalare di due vettori.

2) per prendere il numero di celle di un intervallo che soddisfa un qualche criterio.

La sintassi è:

=MATR.SOMMA.PRODOTTO(intervallo=criterio)
  • Contiamo il numero di celle che contengono numeri dispari:
in una cella vuota scrivi la formula:
=MATR.SOMMA.PRODOTTO(DISPARI(A1:A20))

e premi Invio.

  • Contiamo il numero di celle che contengono numeri maggiori rispetto alla media dei valori dell'intervallo:
in una cella vuota scrivi la formula:
=MATR.SOMMA.PRODOTTO(A1:A20>MEDIA(A1:A20))

e premi Invio.

  • Contiamo il numero di celle che contengono numeri dispari e che sono maggiori rispetto alla media dei valori dell'intervallo:
In una cella vuota scrivi la formula:
=MATR.SOMMA.PRODOTTO((A1:A20>MEDIA(A1:A20))*(DISPARI(A1:A20)))

e premi Invio.

3) per sommare numeri in un intervallo quando questi soddisfano certi criteri. La sintassi è:

=MATR.SOMMA.PRODOTTO(somma_intervallo;criterio)

o

=MATR.SOMMA.PRODOTTO((somma_intervallo)*(criterio))

In ogni caso, puoi cambiare l'ordine dei fattori.

  • Sommare i numeri dispari di un intervallo:
  • In una cella vuota digita una delle formule seguenti:
=MATR.SOMMA.PRODOTTO(A1:A20;DISPARI(A1:A20))

o

=MATR.SOMMA.PRODOTTO((A1:A20)*(DISPARI(A1:A20)))

e premi Invio.

  • Sommare tra loro i numeri più grandi della media dell'intervallo:
    In una cella vuota scrivi la formula:
=MATR.SOMMA.PRODOTTO(A1:A20;A1:A20>MEDIA(A1:A20))

e premi Invio.

  • Sommare i numeri dispari che sono anche maggiori della media dell'intervallo:
    In una cella vuota scrivi la formula:
=MATR.SOMMA.PRODOTTO((A1:A20>MEDIA(A1:A20))*(DISPARI(A1:A20))*(A1:A20))

e premi Invio.

Nota Può essere d'aiuto definire gli intervalli di celle.
Supponiamo che le celle dell'intervallo A1:A10 contengano i valori "rosso" o "verde", e che le celle dell'intervallo B1:B10 contengano il valore "grande" o il valore "piccolo". Per contare le volte in cui i valori delle celle sono contemporaneamente "rosso" e "piccolo" potresti scrivere la formula:

=MATR.SOMMA.PRODOTTO(A1:A10="rosso";B1:B10="piccolo")

o

=MATR.SOMMA.PRODOTTO((A1:A10="rosso")*(B1:B10="piccolo"))

in C1.
Ma puoi anche definire gli intervalli A1:A10 e B1:B10. Per farlo:

  • Seleziona l'intervallo A1:A10.
  • Vai al menù Dati e scegli Definisci Area….
  • Nella finestra Definisci area database che appare, scrivi un Name, per esempio "colori" (senza le virgolette).
  • Clicca su Aggiungi poi sul bottone OK.
  • Fai la stessa cosa per l'intervallo B1:B10 che potresti chiamare "dimensioni"
  • Adesso puoi scrivere la formula:
=MATR.SOMMA.PRODOTTO(colore="rosso";dimensioni="piccolo")

o

=MATR.SOMMA.PRODOTTO((colore="rosso")*(dimensioni="piccolo")).


Questo articolo in altre lingue: English Français
Personal tools