NeoOffice 3.0 Early Access Development Issues

From NeoWiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 15:23, 5 December 2008 (edit)
Pluby (Talk | contribs)
(Reclassify Apple Remote issue as Not a Bug - Feature Request)
← Previous diff
Revision as of 16:34, 5 December 2008 (edit) (undo)
Lorinda (Talk | contribs)
(Unconfirmed issues - add issues about docking palettes and showing hidden characters when printing.)
Next diff →
Line 16: Line 16:
* Aqua focus rings on pop-up menus (e.g., "Help formatting" in Preferences:NeoOffice:General) are clipped. * Aqua focus rings on pop-up menus (e.g., "Help formatting" in Preferences:NeoOffice:General) are clipped.
* Aqua focus rings on editable comboboxes (e.g., in the Find/Replace dialogue) are clipped. * Aqua focus rings on editable comboboxes (e.g., in the Find/Replace dialogue) are clipped.
 +* Cannot Dock the Styles and Formatting palette. To reproduce: Click on the Styles and Formatting button on the toolbar. In the new double-click in the grey area just under the window name. Nothing happens. (Sometimes this is true in 2.2.5 as well.) Second method: drag the window to the left or right edge of the main document window and pause. in Neo 2.2.5, in a second or two a grey box outline will appear. If you let go of the window when it does, it will dock the palette on that side. This does not happen in NeoOffice 3.0. The Help file says it should work that way.
 +*When printing, Hidden characters (paragraph marks, etc.) appear in the document briefly. File>Print>OK (or Preview). Then click OK in the Neo-specific dialog. Watch the document in Neo: Hidden characters will suddenly appear, then disappear. This does not happen in Neo 2.2.5.
== Unfixed issues == == Unfixed issues ==

Revision as of 16:34, 5 December 2008

This page is for tracking any issues that we find during the development of NeoOffice 3.0 Early Access. Once NeoOffice 3.0 Early Access is released, we will record all issues in Bugzilla.

Contents

Unconfirmed issues

  • Using Cmd-O multiple times (e.g. 5) displays the Open dialog; after closing the dialog (clicking Cancel), another dialog appears, until you close all 5 dialogs. In 2.2.5, only one dialog can be opened, except when all windows are closed, where multiple dialogs do open but all show (whereas there is only one dialog showing at a time in 3.0). (edit by pluby: I can reproduce this in NeoOffice 2.2.5, can you?)
  • Rulers display in "Characters" despite being set to "Inches" everywhere in Preferences (edit by pluby: I cannot reproduce this with the 10/31/2008 test build) (I can reproduce this in the 10/31/2008 build when it migrates existing 2.2 prefs. In fact, I get completely different sets of preferences in Writer:General when Neo3 imports Neo2 prefs vs not importing prefs. —sardisson)
  • Old icons are used in toolbars if toolbar preferences are copied over manually from the 2.2 preferences file. (I realize this may not be a bug, but I thought I should report it. My toolbar settings did not transfer over automatically, so I copied the relevant folder. But then I lost the nice new icons!) On a PPC machine.
  • Drawing metrics off for combo boxes; the popup buttons on the right hand side of non-editable combo boxes are a few pixels misaligned to the right and top. Editable seems fine, but not all of the region is updated when going from disabled to enabled (Tools > Options > NeoOffice > Fonts, check/uncheck "Apply Replacement Table") (edit by pluby: does this still occur in the 11/13/2008 test patch?) Edit by Samwise: still occurs for me with the 11/13 test patch; use same steps as above (check/uncheck "Apply Replacement Table"). (another edit by pluby: is the behavior in the 11/21/2008 test patch any different than NeoOffice 2.2.5?) (The behaviors with editable comboboxes appear to be equally buggy in NeoOffice 2.2.5; oddly enough, the font replacement comboboxes redraw to disabled without alignment errors when the app or window becomes background, but not when being disabled by the checkbox. Other editable comboboxes, like the Styles combobox in the Writer toolbar, exhibit the redraw alignment error when their window becomes background. I don't observe any redraw issues with non-editable comboboxes, such as the Resolution one in Preferences:NeoOffice:Print. —sardisson)
  • Frame widget types not functioning in Tools > Spelling and Grammar (edit by pluby: does this still occur in the 11/21/2008 test patch?)
  • Frame wells in Templates and Documents are Win95 style, not OS X style. Also see table list in Tools > Options > NeoOffice > Fonts (edit by pluby: does this still occur in the 11/21/2008 test patch?)
  • List Box wells are Win95 style, not OS X widgets (see Help > NeoOffice Help, both search term list and rendered content area) (edit by pluby: does this still occur in the 11/21/2008 test patch?)
  • Unusual continual redrawing of document boundary and uneven cursor timer flashing in documents opened from finder if the window is moved prior to final document opening. (edit by pluby: does this still occur in the 11/21/2008 test patch?)
  • Can't access custom macros created in NeoOffice 2.2.5. I've moved over the basic folder from the 2.2.5 preferences, but Neo 3.0EA isn't able to find them. This is on a PPC machine running 10.4.11. [time passes] O.k. this is bizarre. Now the macros show up just where they are supposed to in NeoOffice 3.0 EA. I don't know what changed, although I did get several Basic errors when starting the app up this time.
  • I am now getting "Error Loading Basic" messages when starting NeoOffice 3.0 EA. The same screen appears twice, but once I've clicked OK in both of them, the application opens fine. Since the file in question is buried in the NeoOffice app itself, I'm not sure how to clear it. IIRC this started after I ran Neo 2.2.5 because I needed a macro I couldn't access from 3.0 EA. Here's a screen shot, since the path is so long (and not copyable):
Image:Error Loading Basic.png
  • Aqua focus rings on pop-up menus (e.g., "Help formatting" in Preferences:NeoOffice:General) are clipped.
  • Aqua focus rings on editable comboboxes (e.g., in the Find/Replace dialogue) are clipped.
  • Cannot Dock the Styles and Formatting palette. To reproduce: Click on the Styles and Formatting button on the toolbar. In the new double-click in the grey area just under the window name. Nothing happens. (Sometimes this is true in 2.2.5 as well.) Second method: drag the window to the left or right edge of the main document window and pause. in Neo 2.2.5, in a second or two a grey box outline will appear. If you let go of the window when it does, it will dock the palette on that side. This does not happen in NeoOffice 3.0. The Help file says it should work that way.
  • When printing, Hidden characters (paragraph marks, etc.) appear in the document briefly. File>Print>OK (or Preview). Then click OK in the Neo-specific dialog. Watch the document in Neo: Hidden characters will suddenly appear, then disappear. This does not happen in Neo 2.2.5.

Unfixed issues

  • Does the MediaWiki integration work (Preferences:Internet:MediaWiki)? If not, can we suppress it? I can't get it to establish a connection with the NeoWiki or Camino wiki. —sardisson (edit by pluby: the network connectivity code in this extension is apparently buggy so I will remove this extension in the next full test build)
  • Writer uses a new/wrong "Spelling and Grammar" icon, while Calc and everything else still uses the correct icon. (edit by pluby: does Armando know about this?)
  • Link to "get more templates online" goes to go-oo.org...probably others for extensions maybe? Redirect to our own site?
  • Investigate Tools > Options > NeoOffice > Online Update > Download Updates Automatically...what do we need to do? Change implementation, or remove?
  • Save icon is not dim when new document opened and does not dim when changes saved.
  • Unlike other widgets, checkboxes and radio buttons don't switch to grey when their window or the app goes to the background (bug exists in 2.2.5 on 10.5.5/Intel/Java1.5 also, but *not* in 2.2.5 on 10.3.9/PPC/Java1.4,2; does it work correctly in 3.0EA on PPC, or on 10.4/Intel or other combinations?). (edit by pluby: this bug occurs in both 2.2.5 and 3.0 EA but only on Mac OS X 10.5.x so I have filed bug 3305)
  • The text-field part of a spinner widget gets a partial focus ring drawn around it (as opposed to no focus ring at all in 2.2.5 or a full focus ring for normal text fields in 3.0EA); see "Scaling" spinner in Preferences:NeoOffice:View.
  • Ctrl-A and Ctrl-E do not move the cursor to the beginning or end of line.

Closed

OpenOffice.org bug

  • Note: redundant extra column (but not extra row) in the Table button graphical size selector (which you get if you click on the dropdown triangle instead of the button) is an OpenOffice v3 bug, not a NeoOffice bug.
  • When opening documents, moving the window while document is opening does not preserve position; window will jump back after documents are opened

ooo-build bug

  • Note: wrong description for 'Toggle Grid Lines for the Current Sheet' button in Formatting toolbar, when viewed in Tools::Customise::Toolbars (it has the one meant for Edit::Changes::Record) - this is an ooo-build bug, they're going to fix it.
  • Calc: after copying a cell (or cells) to the clipboard (using e.g. cmd-c), a pale blue frame is drawn round that cell - visible when using Toggle Grid Lines. Doesn't go away until another selection is copied to the clipboard.

Not a bug - Feature Request

  • NeoOffice 3 installer immediately runs NeoOffice, doesn't let me install a patch first if I have it. Better behaviour would be to ask if NeoOffice should be started. (edit by pluby: this behavior has been standard in the NeoOffice installation since NeoOffice 2.1 so closing as this is a feature request)
  • Default downloads destination (in Online Update preferences) should use default Mac OS X download directory from LaunchServices/InternetConfig rather than hard-coding ~/Downloads.
  • There seem to be options in the Menu::NeoOffice::Preferences that are used in OOo code, but not in the nativied NeoOffice replacements. I presume the settings for using native file and print dialogs, OpenGL, screen font anti-aliasing, show icons in menus and (possibly) proxy are obsolete and superseded by things inherited from OSX. It might be good to gray these out, even if they cannot be entirely removed. If not, at least documentation should be somewhere that tells a user what these settings still accomplish (ovvldc).
  • Checkboxes and radiobuttons have no focus rings (this seems to have existed since Aqua widgets landed in Neo).
  • Apple Remote doesn't work when NeoOffice 3 has focus (in Writer doc) (edit by yoxi: no, I meant that when Neo 3 has focus, Apple Remote doesn't work at all, e.g. to pause iTunes playback, change system volume - normally you can use the remote on iTunes etc. when another app has focus) (edit by pluby: the current behavior is normal and is the same as when the QuickTime Player application has focus. Specifically, both NeoOffice and QuickTime Player grab exclusive access to the remote when they have focus. What you are seeing with iTunes is that the application with focus does not support the Apple Remote so iTunes retains exclusive access to the remote until a different application that supports the remote gets focus).

Fixed issues

  • Italic angle in Writer in wrong (fixed in 10/15/2008 test patch)
  • NeoOffice :: About and NeoOffice :: Preferences do not work (fixed in 10/15/2008 test patch)
  • Start Center shows when all documents are closed (fixed in 10/15/2008 test patch)
  • None of the Tools :: Add-ons work (fixed in 10/15/2008 test patch)
  • Splash screen progress bar flickers (fixed in 10/15/2008 test patch)
  • Enable odf-converter for export of Office 2007/2008 files (fixed in 10/21/2008 test build)
  • Upgrade to odf-converter 2.0 code (fixed in 10/21/2008 test build)
  • Crashes when launched by opening a document in the Finder (fixed in 10/21/2008 test build)
  • Exported PDF files have corrupted embedded fonts (fixed in 10/21/2008 test build)
  • Image Capture extension is still not properly loading (10.5 PowerPC), but issues with grammar and media browser service loading are resolved (fixed in 10/21/2008 test build)
  • On PowerPC, dlopen() function calls for module libraries (libsw, libsc, etc.) are 10 times slower than in earlier OOo versions (fixed in 10/21/2008 test build)
  • Native spellchecker code is not being loaded (fixed in 10/21/2008 test build)
  • Dragging within NeoOffice does not work but dragging to or from other apps works (fixed in 10/21/2008 test build)
  • Extension Manager - updates to bundled Presentation Minimiser & Presenter Console not possible: 'The extension cannot be installed because: No write permission (shared extension).' (fixed in 10/31/2008 test build by disabling update check for read-only shared extensions)
  • Possible font cache corruption, see bug 3273 (fixed in 10/31/2008 test build)
  • Extension Manager - installing AltSearch.oxt extension breaks Extension Manager; all buttons greyed out except Help and Close, not possible to select other extensions. (fixed in 10/31/2008 test build)
  • Update problems in Extension Manager; simply scroll list, note that not all icons to the left of entries are not always drawn. PowerPC (fixed in 10/31/2008 test build)
  • On PowerPC, icon for media browser extension in toolbar does not display (fixed in 10/31/2008 test build)
  • Toolbar icons in Writer that get obscured by tooltips do not redraw properly; portion of icon that was obscured does not get repainted (fixed in 10/31/2008 test build)
  • Tooltip drawing/updates over tables can undo XOR drawing: Create table in writer with multiple rows, select entire table, move mouse over boundary positions just to the left of left table edge to get "Select row" style tooltips, watch XOR get reversed when obscured portion is unnecessarily redrawn (fixed in 10/31/2008 test build)
  • Scrolling with scrollbar that causes tooltips to appear for Headings in a Writer document may result in portions of writer document that were obscured by the tooltips from being redrawn properly (fixed in 10/31/2008 test build)
  • Change Thesaurus module to use PRODUCT_NAME (Tools > Options > Language Settings > Writing Aids > Available Language Modules) (fixed in 10/31/2008 test build)
  • "Close" button in the popup lightbulb help assistant no longer displays the "X" to close...it's now just an empty well. (fixed in 10/31/2008 test build)
  • Size adjustment handles not appearing on images embedded in Writer documents (e.g. blue square handles to change horizontal/vertical bounds) (edit by pluby: I cannot reproduce this with the 10/31/2008 test build) (Ed - verified fixed in 10/31/08 test build)
  • Attempting to adjust scrollbar by click-dragging thumb will cause thumb of scrollbar to disappear, text to scroll to top (Ed - fix committed 11/9/08) (fixed in 11/13/2008 test patch)
  • Frame widget types not functioning (see Tools > Options sub panels in the right...the Win95ish panel should be replaced with the native frame widget type, similar to a tab well background) (Ed- fix committed 11/9/08) (fixed in 11/13/2008 test patch)
  • 'Check for Updates' flags a patch-0 update as available, but Download button goes to EAP postponement web page. (fixed in 11/13/2008 test patch)
  • Listboxes and comboboxes are clipped (fixed in 11/13/2008 test patch)
  • Spinners do not render natively (fixed in 11/13/2008 test patch)
  • Text fields are too small (fixed in 11/13/2008 test patch)
  • Tools>Customize>Keyboard: If I try to drag the scroll lozenge (the little blue oval), it disappears. It only reappears when one of the scroll arrows is clicked on. Scrolling is only possible with the arrows, and then is often inconsistent. This is on a PPC machine. More: The same is true of the scroll lozenges in the main document window. The mouse scroll ball and scrolling on the trackpad work correctly, and the lozenges move in sync with this scrolling.—Lorinda (fixed in 11/13/2008 test patch)
  • Text in spinners' text fields exhibits "cheap whore" behavior (fixed in 11/13/2008 test patch)
  • Redundant separator in Help menu after "Check for Updates" (fixed in 11/13/2008 test patch)
  • Media Browser customizations for including NeoOffice Gallery in Photos and Music need to be updated to refer to the new path locations in the tri-level structure breakdown (fixed in 11/13/2008 test patch)
  • Need to check the online help content displayed by Help > Support to use corrected PRODUCT_NAME and our own support URLs (or redirect Support to open Trinity forums in a browser). (fixed in 11/13/2008 test patch)
  • Double-clicking timing issue on PowerPC seems to have reappeared; need to triple-click to select word in Writer instead of double-click. This was fixed by 2.2.5 patch 1 (?) so may be missing code that needs to be merged from the branch to HEAD (fixed in 11/13/2008 test patch)
  • Button flicker when using DateIssu.odb file from bug 3044 (to reproduce, Ctrl-click on the Form, choose Open). No flicker in 2.2.5 with the same file. (fixed in 11/21/2008 test patch)
  • Printing in Writer with View :: Web View menu set: after NeoOffice print options dialogue closes, main doc window shows hidden characters (e.g. paragraph marks) and then hides them again. (fixed in 11/21/2008 test patch)
  • Scrollbar hit testing does not match arrows when double-arrows preference is set (fixed in 11/21/2008 test patch)
  • Focus rings for edit fields are not properly erasing...missing forced updates from our previous custom code on losing and gaining focus. See shifting focus in Tools > Options in the panel for entering user name and info...focus rings are not erased when tabbing through edit fields (fixed in 11/21/2008 test patch)
Personal tools