It:Elenco dei termini unici in un intervallo di celle

From NeoWiki

(Difference between revisions)
Jump to: navigation, search

Valterb (Talk | contribs)
(New page: {{fixmeIT}} Supponiamo che tu abbia una colonna in un foglio elettronico, nella quale diverse colonne assumono lo stesso valore. Supponiamo poi di desiderare avere un elenco dei termini u...)
Next diff →

Revision as of 13:20, 23 December 2007

Questo articolo non è aggiornato, o ha bisogno di cambiamenti strutturali o stilistici per conformarsi al resto del wiki. Puoi aiutare alla comunità di NeoOffice sistemandolo.

Supponiamo che tu abbia una colonna in un foglio elettronico, nella quale diverse colonne assumono lo stesso valore. Supponiamo poi di desiderare avere un elenco dei termini unici presenti nella lista e mostrare quante volte ciascun termine appare nell'elenco. NeoOffice permette di fare questa cosa usando la funzione CERCA.VERT.

ESEMPIO
Supponiamo che l'intervallo A1:A14 contenga i nomi di colori, viola, rosso, blu, verde, e ciascuno di questi appaia un certo numero di volte nell'elenco.
Usa il metodo seguente:

  • Inserisci due nuove colonne a sinistra della colonna A. In questo modo i valori della colonna A adesso si trovano nella nuova colonna C.
  • Seleziona la cella A1, e digita la formula
    =SE(CONTA.SE(C$1:C1;C1)>1;0;1)
  • Premi il tasto the Invio.
  • Copia questa formula nelle celle sottostanti (vedi l'articolo Selezione e Compilazione di un'area di celle nel NeoWiki).
  • Seleziona la cela B1, e scrivi la formula
    =SOMMA(A$1:A1)
  • Premi il tasto Invio.
  • Copia questa formula verso il basso.
    Otterrai così una colonna contenente il valore 1 accanto a ciascuno dei colori quando questi appaiono la prima volta nell'elenco, ed una colonna che contiene il numero di ripetizioni di ciascun colore.
  • Crea un intervallo che contiene i primi 14 numeri interi, p.e. nell'intervallo E1:E14.
  • Seleziona la cella D1, e scrivi la formula
    =CERCA.VERT(E1;B$1:C$14;2;0)
  • Premi il tasto Invio.
  • Copia la formula verso il basso.
    Noterai che ci sono sono 4 colori elencati, ed a partire dalla quinta colonna otterrai il messaggio di errore #N/A. Per questo motivo dobbiamo modificare leggermente la formula per sistemare questo problema.
  • Seleziona la cella F1, e scrivi la formula
    =SE(VAL.NON.DISP(CERCA.VERT(E1;B$1:C$14;2;0));"";CERCA.VERT(E1;B$1:C$14;2;0))
  • Premi il tasto Invio.
  • Copia questa formula in basso.
  • Seleziona la cella G1, e digita la formula
    =MATR.SOMMA.PRODOTTO(C$1:C$14=F1)
  • Premi il tasto Invio.
  • Copia la formula verso il basso.

Image:Elenca_celle.png


Questo articolo in altre lingue: English Français
Personal tools