Fr:Problèmes d'installation de NeoOffice

From NeoWiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 18:34, 20 December 2006 (edit)
Jgd (Talk | contribs)
(link ->Fr:Notes_sur_actualisations (delete old link))
← Previous diff
Revision as of 16:51, 1 January 2007 (edit) (undo)
Jgd (Talk | contribs)
m (rename Fr:Instructions de désinstallation de NeoOffice)
Next diff →
Line 17: Line 17:
==Avant l'installation== ==Avant l'installation==
===Dois-je tout d'abord désintaller les versions antérieures de NeoOffice ?=== ===Dois-je tout d'abord désintaller les versions antérieures de NeoOffice ?===
-Les utilisateurs posent souvent la question de la [[Fr:Instruction de désinstallation de NeoOffice|désinstallation]] préalables d'anciennes version de NeoOffice. En bref, la réponse est '''NON''' ; dans les faits, une désinstallation complète d'une version antérieure conformément aux instructions avant lancement de la nouvelle version détruirait vos préférences existantes, vos macros, réinitialiserait les dictionnaires et effacerait d'autres fichiers utilisateurs.+Les utilisateurs posent souvent la question de la [[Fr:Instructions de désinstallation de NeoOffice|désinstallation]] préalables d'anciennes version de NeoOffice. En bref, la réponse est '''NON''' ; dans les faits, une désinstallation complète d'une version antérieure conformément aux instructions avant lancement de la nouvelle version détruirait vos préférences existantes, vos macros, réinitialiserait les dictionnaires et effacerait d'autres fichiers utilisateurs.
NeoOffice 2.0 s'installera par dessus NeoOffice en version 1.2.2, remplacera l'ancienne version tout en préservant un certain nombres de fichiers utilisateur livrés avec l'application. À la première exécution, NeoOffice 2.0 proposera d'importer vos préférence de NeoOffice 1.2.2. Après mise à jour, assurez-vous d'[[Changing_the_Language_of_the_User_Interface#Upgrading_NeoOffice_and_language_packs|installer la version la plus récente des packs de langues]] et de <!-- [[Activating_Dictionaries#Activating_the_Writing_Tools_for_Your_Preferred_Language|contrôler les mises à niveau des différents dictionnaires installés]]. --> NeoOffice 2.0 s'installera par dessus NeoOffice en version 1.2.2, remplacera l'ancienne version tout en préservant un certain nombres de fichiers utilisateur livrés avec l'application. À la première exécution, NeoOffice 2.0 proposera d'importer vos préférence de NeoOffice 1.2.2. Après mise à jour, assurez-vous d'[[Changing_the_Language_of_the_User_Interface#Upgrading_NeoOffice_and_language_packs|installer la version la plus récente des packs de langues]] et de <!-- [[Activating_Dictionaries#Activating_the_Writing_Tools_for_Your_Preferred_Language|contrôler les mises à niveau des différents dictionnaires installés]]. -->
Line 25: Line 25:
NeoOffice 2.0 s'installe séparément de NeoOffice/J 1.1 dans <tt>Applications</tt> et propose d'importer les préférences de NeoOffice/J 1.1 dans le nouveau dossier de préférences au premier lancement de l'application. À partir de ce moment, vous pouvez utiliser l'une ou l'autre des versions sans affecter l'autre. Après avoir installé NeoOffice 2.0, assurez-vous d'[[Changing_the_Language_of_the_User_Interface#Upgrading_NeoOffice_and_language_packs|installer la version la plus récente des packs de langues]] et de [[Fr:Installer_des_Dictionnaires#Activer_les_Outils_Linguistiques_pour_votre_Langue_Préférée|contrôler les mises à niveau des différents dictionnaires installés]]. NeoOffice 2.0 s'installe séparément de NeoOffice/J 1.1 dans <tt>Applications</tt> et propose d'importer les préférences de NeoOffice/J 1.1 dans le nouveau dossier de préférences au premier lancement de l'application. À partir de ce moment, vous pouvez utiliser l'une ou l'autre des versions sans affecter l'autre. Après avoir installé NeoOffice 2.0, assurez-vous d'[[Changing_the_Language_of_the_User_Interface#Upgrading_NeoOffice_and_language_packs|installer la version la plus récente des packs de langues]] et de [[Fr:Installer_des_Dictionnaires#Activer_les_Outils_Linguistiques_pour_votre_Langue_Préférée|contrôler les mises à niveau des différents dictionnaires installés]].
-Si vous ne voulez plus garder une des versions, suivez les [[Fr:Instruction de désinstallation de NeoOffice |instructions de désinstallation]] ; assurez-vous de '''vider la corbeille''' ou bien les documents ne pourront s'ouvrir avec la version restante (C'est un bug Apple).+Si vous ne voulez plus garder une des versions, suivez les [[Fr:Instructions de désinstallation de NeoOffice |instructions de désinstallation]] ; assurez-vous de '''vider la corbeille''' ou bien les documents ne pourront s'ouvrir avec la version restante (C'est un bug Apple).
<!-- <!--

Revision as of 16:51, 1 January 2007


Contents

Avant l'installation

Dois-je tout d'abord désintaller les versions antérieures de NeoOffice ?

Les utilisateurs posent souvent la question de la désinstallation préalables d'anciennes version de NeoOffice. En bref, la réponse est NON ; dans les faits, une désinstallation complète d'une version antérieure conformément aux instructions avant lancement de la nouvelle version détruirait vos préférences existantes, vos macros, réinitialiserait les dictionnaires et effacerait d'autres fichiers utilisateurs.

NeoOffice 2.0 s'installera par dessus NeoOffice en version 1.2.2, remplacera l'ancienne version tout en préservant un certain nombres de fichiers utilisateur livrés avec l'application. À la première exécution, NeoOffice 2.0 proposera d'importer vos préférence de NeoOffice 1.2.2. Après mise à jour, assurez-vous d'installer la version la plus récente des packs de langues et de contrôler les mises à niveau des différents dictionnaires installés.

Mise à niveau depuis NeoOffice/J 1.1

NeoOffice 2.0 s'installe séparément de NeoOffice/J 1.1 dans Applications et propose d'importer les préférences de NeoOffice/J 1.1 dans le nouveau dossier de préférences au premier lancement de l'application. À partir de ce moment, vous pouvez utiliser l'une ou l'autre des versions sans affecter l'autre. Après avoir installé NeoOffice 2.0, assurez-vous d'installer la version la plus récente des packs de langues et de contrôler les mises à niveau des différents dictionnaires installés.

Si vous ne voulez plus garder une des versions, suivez les instructions de désinstallation ; assurez-vous de vider la corbeille ou bien les documents ne pourront s'ouvrir avec la version restante (C'est un bug Apple).


Problèmes d'installation

Quand je double-clique sur le fichier .dmg, il apparaît le message d'erreur "Le système de fichiers ne peut pas être monté"

Cette erreur signifie généralement que le fichier NeoOffice.dmg n'est pas complètement téléchargé. Quelques configurations de navigateurs et de connections internet causent fréquemment l'arrêt des gros téléchargements comme NeoOffice avant que le fichier ne soit complètement téléchargé sans pour autant avertir l'utilisateur de l'échec du téléchargement.

Dans ce cas, vous pouvez utiliser la commande curl depuis le terminal pour terminer le téléchargement (cette commande est utile également dans le cas ou vous utilisez une connexion par modem RTC et voulez interrompre les téléchargements pour laisser place à une conversation téléphonique puis reprendre le téléchargement une fois qu'elle est terminée). Les instructions d'utilisation de curl pour télécharger NeoOffice sont Fr:Utiliser_curl_pour_télécharger_NeoOffice


Pendant l'exécution du programme d'installation de NeoOffice, le "test" renvoie le message "NeoOffice ne peut pas être installé sur cet ordinateur."

Le sous-système BSD est installé par défaut dans 10.3.x et 10.4.x en tant qu'élément du paquet BaseSystem.pkg. Si ce problème survient sur une machine en 10.3.x, votre sous-système BSD a peut-être été désinstallé ou corrompu. Il n'est poas recommandé de réinstaller le paquet BaseSystem.pkg seul, cela risque de rendre votre système inutilisable. Au lieu de cela, réinstallez Mac OS X depuis vos CD d'installation ; sélectionnez l'option "Mettre à jour", cela préservera vos documents, préférences et paramétrages divers. Réinstaller ensuite les dernières mises à jour de Mac OS X et les dernières mises à jour de sécurité pour remonter votre système à la dernière version disponible.

N.B. : Comme cette opération demande une quantité de travail certaine et un peu de temps, il est astucieux de faire tout d'abord un tour sur le forum de Trinity pour voir si quelqu'un peut vous aider à déterminer si le problème ne serait d'une autre nature et vous trouver une autre solution.

L'installation a échoué avec affichage d'un message d'erreur "générique"

Pour quelques utilisateurs, l'installation peut échouer sur l'affichage d'erreur suivant :

Il y a eu des erreurs pendant l'installation du logiciel
Veuillez recommencez l'installation.

Si vous obtenez ce message, ouvrez les préférences système (/Applications/Préférences système), cliquez sur l'icone International, sélectionnez l'onglet Langues, déplacer English en haut de la liste, déconnectez-vous, reconnectez-vous et relancer le programme d'installation. Après l'installation, vous pouvez (et devriez) revenir à votre langue de prédilection.

Cette façon de faire est nécessaire pour contourner un bug rare mais grave de l'installeur Mac OS X sur quelques versions de Mac OS X ; pour plus d'informations, rendez-vous à cette section des instructions de téléchargement.

Pourquoi le programme d'installation de NeoOffice demande le mot de passe de l'administrateur ?

Sur ce fil de discussion, Patrick Luby explique les raisons de cette contrainte:

Un accès d'administrateur est requis parce que NeoOffice/J utilise l'installation multi-utilisateur de OpenOffice.org. Ce type d'installation ne réclame pas de code d'administrateur mais, dès les premiers test de Neo/J, nous constatâmes que le code de OOo tentait de modifier les fichiers installés s'il étaient propriété de l'utilisateur de Neo/J. Ceci pouvait réellement pourrir un Neo/J avec le temps.


Donc, pour prévenir la modification des fichiers installés, l'installateur exécute la commande chown -Rf root:admin et chmod -Rf a-w pour tous les fichiers de Neo/J.

Quand la mise à niveau s'effectue depuis la version NeoOffice/J 1.1 Alpha ou antérieure, la vieille icone marron reste dans le Dock

Pour ceux qui mettent à niveau depuis 0.x ou 1.1 Alpha vers1.1 beta ou plus (1.2 Alpha comprise), la nouvelle icone (un bateau marron clair dans un cercle bleu foncé) n'apparaît pas dans le Dock si l'ancienne icone marron y était déjà. Glissez l'icone hors du dock, lâchez-la, petit nuage et poof ; lancer alors NeoOffice, la nouvelle icone apparaît dans le dock, cliquez-droit sur l'icone et choisissez Conserver dans le Dock.

Les problèmes dus aux correctifs

L'installation d'un correctif échoue avec un message d'erreur «générique»

Pour quelques utilisateurs, l'installation échoue sur l'affichage d'erreur suivant :

Il y a eu des erreurs pendant l'installation du logiciel
Veuillez recommencez l'installation.

Reportez-vous à L'installation a échoué avec affichage d'un message d'erreur "générique" dans la section Problèmes d'installation ci-dessus.

Le programme d'installation des correctifs refuse de démarrer l'installation

Sous Mac OS X 10.3.x et 10.4.x, le programme d'installation peut afficher un panneau «Stop» rouge avec un point d'exclamation. En cliquant sur l'icone du volume, le message d'erreur suivant apparaît : «Vous ne pouvez pas installer ce logiciel sur ce volume», c'est tout ce que vous obtenez comme information complémentaire. (ou bien en 10.4.x, «Message spécifié introuvable pour l'index 16», ce qui est une anomalie du programme d'installation de 10.4.x).

Deux conditions peuvent conduire à l'apparition de ce message d'erreur.

Ce correctif est prévu pour une version de NeoOffice plus récente que celle installée sur votre ordinateur

Les correctifs pour NeoOffice 1.2.x ne peuvent pas s'appliquer aux versions de NeoOffice/J et aux versions antérieures. Chaque fois que NeoOffice utilise une nouvelle version du code de OpenOffice.org (versions mineures inclues ), les correctifs applicables à cette nouvelle version sont incompatibles avec les versions antérieures. NeoOffice 1.2.x utilise le code de OpenOffice.org 1.5.5 tandis que NeoOffice/J 1.1 (version finale) utilise le code de OpenOffice.org en version 1.1.4. Comme décrit sur Ce fil de discussion, «Ce serait comme appliquer la mise à jour Mac OS X 10.3.1 sur Mac OS X 10.2.8....»

Ouvrez NeoOffice puis sélectionnez À propos de dans le menu Aide, la version de NeoOffice est alors affichée, elle doit être NeoOffice 1.2.2 (en Mars 2006).

Pour contourner ce problème, déplacez NeoOffice du dossier Application vers la corbeille.Téléchargez alors et installez la version la plus récente de NeoOffice ainsi que le dernier paquet de correctifs. regardez aussi les notes de version de NeoOffice pour connaître la derrnière version.

NeoOffice n'est pas installé dans le répertoire Applications

Problèmes survenant après l'installation et au premier lancement de NeoOffice

Contrôlez le réglage de la langue de NeoOffice avant le lancement de NeoOffice

NeoOffice prend la première langue dans la liste présentée dans l'onglet Langues du panneau International des Préférences Systèmes de Mac OS X pour procéder aux corrections orthographiques (étant acquis que le Pack de langues nécessaire est déjà installé ou bien que la langue choisie est une des 12 langues de base).


Veuillez noter que certaines langues ont plusieurs formes (le Français présente ainsi les formes Français canadien et Français suisse) qui peuvent être chacune sélectionnées : Avant le premier lancement de NeoOffice, cliquez sur l'onglet Langues du panneau International des Préférences Système de Mac OS X puis appuyez sur le bouton Modifier la liste ... cochez pour ajouter la forme de votre langue, fermez par OK puis, sur la liste, Positionnez la forme de langue voulue en tête de liste par glisser-déposer.

Consultez Activation des dictionnaires pour ce qui concerne les problèmes survenant avec certaines langues.

Pourquoi NeoOffice 1.2.x semble "planté" pendant le démarrage ?

NeoOffice 1.2.x semble "planté" (la barre de progression est coincée entre le "n" et le "O" de "OpenOffice.org)) pendant le démarrage. C'est une chose totalement normale ; Cette pause est due à l'initialisation des polices natives. NéoOffice/J 1.1 et les versions antérieures initialisaient les polices de caractères durant le temps, assez long, avant l'apparition de l'écran d'accueil, le problème était donc moins visible ; néanmoins, certaines personnes arrivaient à se demander si l'application était réellement lancée !

La durée de l'attente dépend du nombre de polices de caractères installées ; le délai peut être considérablement raccourci en désactivant les polices inutilisées via le Livre des Polices. Attention à ne pas désactiver les polices nécessaires au bon fonctionnement de Mac OS X. La liste des polices indispensables à Mac OS X 10.3.x se trouve [ici].

Vous pouvez également constater un temps de lancement assez long après que vous ayez rebooté votre Mac. C'est normal au premier lancement de NeoOffice après le reboot, toutes les polices doivent être chargées. C'est au fait que le code de OpenOffice.org requiert des données sur toutes les polices disponibles. Ce chargement allonge la période de lancement de NeoOffice à sa première exécution (après un départ à froid). Les démarrages successifs (redémarrages à chaud) de NeoOffice seront plus rapides puisque les données des polices sont déjà chargées.

Ce n'est plus un problème depuis NeoOffice 2.0 Alpha 4 Patch 1, les polices de caractères sont initialisées seulement quand elles sont utilisées (en contrepartie, le menu déroulant «Polices» affiche les noms de polices tous écrits avec la même police de caractères : celle de l'interface utilisateur).

Pourquoi ne puis-je pas utiliser NeoOffice sous "root" ?

Sur ce fil de discussion, Patrick Luby en explique les raisons.

L'exécution sous le compte root est désactivée à dessein. Il y a plus d'un an, j'ai ajouté cette partie de code parce que nous constatâmes que l'exécution sous le compte root amenait le code de OpenOffice.org à se comporter comme s'il était dans un contexte mono-utilisateur. Dans ce contexte, OpenOffice.org écrit les préférences de l'utilisateur dans les fichiers Applications/NeoOffice.app. Ceci amenait en fait à rendre NeoOffice quasiment inutilisable pour tout autre utilisateur de votre machine.


La seule façon d'exécuter NeoOffice quand vous êtes loggé sous le compte root est d'exécuter NeoOffice comme utilisateur non-root depuis le terminal:
sudo -H -u <nom-de-l'utisateur-non-root> /Applications/NeoOffice.app/Contents/MacOS/soffice.bin
Notez que les paramètres "-H" and "-u" doivent être utilisés.

Notez également que se connecter en root (ou même l'activer seulement) est déconseillé sous Mac OS X ; celui qui le fait doit être expérimenté comme administrateur UNIX et doit avoir de bonnes raisons de la faire.

Pourquoi NeoOffice accède t-il à internet au premier lancement ?

NeoOffice est régulièrement amélioré. Des anomalies sont corrigées et de nouvelles fonctionnalités sont constamment ajoutées.

Quand vous installez des versions Alpha, Beta ou Candidates à version de NeoOffice et ensuite, environ une fois par semaine, NeoOffice recherche sur internet des nouveaux correctifs et mises à jour ainsi, vous êtes assurés d'avoir toujours un NeoOffice à jour. Si une nouveauté est trouvée, votre navigateur s'ouvrira à la page de téléchargement en question.

Un logiciel «à jour» ne va pas seulement présenter une meilleure stabilité, cela va aussi supprimer un grand nombre de déclarations d'anomalies en double ou déjà corrigées par des correctifs précédents. Cela nous permet de consacrer une plus grande part de nos ressources de développement , somme toutes modestes, à la correction d'anomalies et à l'ajout de fonctionnalités nouvelles.

Ce dispositif de «recherche de correctifs» est souvent désactivée pour les versions finales telles que NeoOffice/J par qu'elles sont stables et bien testées et que les utilisateurs veulent les déployer dans des environnements de production.

NeoOffice est peu performant et les réaffichages sont assez longs. Comment améliorer sa réactivité ?

Les réaffichages sont une conséquence inévitable de l'utilisation conjointe du code de OpenOffice.org et de Java. Quelques uns resteront toujours. Sur une machine rapide, les réaffichages sont rapides et peu remarquables. Pour améliorer la réactivité et la sécurité de NeoOffice, vous devez télécharger et installer la dernière mise à jour Apple de la machine virtuelle Java. La version pour Tiger est ici, la version pour Panther est .

Vous pouvez contrôler votre version de Java en tapant dans le terminal java -version.Si vous avez le message suivant : java version "1.4.2_09" (la dernière à ce jour, ou audessus, vous devriez avoir une bonne réactivité. Vous pouvez trouver une liste chronologique des mises à jour de Java sur ce site Apple.

Pour d'autres réglages permettant d'améliorer les performances, rendez-vous à La section Performance de l'articleGuide de dépannage.

Pourquoi NeoOffice me demande de m'enregistrer au premier lancement ?

L'enregistrement n'est pas nécessaire pour utiliser NeoOffice. C'est simplement pour les développeurs un moyen de connaître qui utilise NeoOffice et vous connecter au site web, aux forums de support et à Bugzilla.

Dois-je faire un don ?

Si vous souhaitez, vous pouvez faire un don pour aider au développement continuel du logiciel, vous êtes encouragé à le faire. Néanmoins, vous n'y êtes obligés.

Dépannage

Pour les autres problèmes connus, voir le guide de dépannage

Comment se débarrasser de NeoOffice ?

Vous avez essayé NeoOffice et décidé qu'il ne vous convenait pas. Cela arrive quelquefois. Vous pouvez suivre les instructions de désinstallation pour retirer NeoOffice sans laisser de traces. Veuillez noter que vous ne pourrez plus lire les documents que vous aurez sauvegardés au format OpenOffice.org.

This article in other languages: English Deutsch Italiano
Personal tools