Fr:Insérer une date fixe dans Calc

From NeoWiki

Revision as of 20:48, 21 February 2008 by Jgd (Talk | contribs)
(diff) ←Older revision | Current revision (diff) | Newer revision→ (diff)
Jump to: navigation, search

Si vous insérez la date et l'heure, dans un document Calc en utilisant la fonction MAINTENANT(), celles-ci seront actualisées chaque fois que vous cliquerez sur Recalculer dans le sous-menu Contenu des cellules… du menu Outils, ou chaque fois que vous rouvrirez votre document après l'avoir enregistré.
Mais vous pouvez avoir besoin de maintenir une date fixée, par exemple pour mesurer le temps que vous avez passé à accomplir une tâche donnée. Pour cela, vous devez utiliser une macro.
Pour connaître tous les formats possibles de date et d'heure :

  • Dans un document Calc allez dans le menu Format, puis choisissez Cellules… et cliquez sur l'onglet Nombres.
  • Sélectionnez Date et Heure dans la section Catégorie pour afficher tous les formats disponibles.

[edit] Enregistrement de la macro

  • Choisissez Enregistrer une macro dans le sous-menu Macros du menu Outils.
  • La fenêtre d'enregistrement des macros s'ouvre.
  • Sélectionnez la cellule devant contenir la date fixe.
  • Entrez dans la barre de formule
TEXTE(MAINTENANT();"JJ/MM/AA HH:MM:SS")

pour afficher la date et l'heure dans le format 15/02/08 10:30:35, ou choisissez le format qui vous convient.

  • Pressez la touche Retour.
  • Choisissez Copier dans le menu Édition , ou pressez les touches Cmd-C.
  • Choisissez Collage spécial… dans le menu Édition, ou pressez les touches Maj-Cmd-V.
  • Dans la fenêtre Collage spécial qui apparait, décochez toutes les cases sauf Chaînes de caractères.
  • Cliquez sur OK.
  • Dans la fenêtre d'avertissement qui s'ouvre, cliquez sur Oui.
  • Dans la fenêtre d'enregistrement de la macro, cliquez sur Terminer l'enregistrement.
  • Donnez un nom à cette macro, par exemple DateFixe.
  • Enregistrez cette macro, en suivant la procédure décrite dans l'article Comment utiliser les macros.
  • Vous pouvez assigner un raccourci clavier ou un bouton à cette macro, en appliquant les méthodes exposées dans cet article.

[edit] Utilisation de la macro

Pour afficher le temps passé à accomplir une tâche, ouvrez le document Calc contenant la macro. Puis

  • Sélectionnez la cellule devant contenir la date de début, par exemple A1.
  • Exécuter la macro DateFixe.
  • Lorsque vous voulez calculer le temps écoulé depuis le début, sélectionnez une cellule vide, par exemple A2, et exécutez la macro DateFixe.
  • Sélectionnez une cellule devant afficher le temps écoulé, par exemple A3.
  • Appliquez à cette cellule le format Heure que vous souhaitez, par exemple HH:MM:SS.
  • Entrez dans la barre de formule
=SI(CNUM(A2)>CNUM(A1);CNUM(A2-A1);"")

et pressez la touche Retour.


Cet article dans d'autres langues : English
Personal tools